seamonkey : seamonkey security update vulnerability

Users of seamonkey please be advised of a seamonkey security update vulnerability that has been identified.
To view this vulnerability, possible remedies, and others please check out the Security Advisories at Critical Watch (http://criticalwatch.com/support/security-advisories.aspx)

RHSA-2010:0557-01: RHSA-2010:0557-01 Critical: seamonkey security update
seamonkey security update
Description:

SeaMonkey is an open source web browser, email and newsgroup client, IRC

chat client, and HTML editor.

An invalid free flaw was found in SeaMonkey’s plugin handler. Malicious web

content could result in an invalid memory pointer being freed, causing

SeaMonkey to crash or, potentially, execute arbitrary code with the

privileges of the user running SeaMonkey. (CVE-2010-2755)

All SeaMonkey users should upgrade to these updated packages, which correct

this issue. After installing the update, SeaMonkey must be restarted for

the changes to take effect.
Read more at http://www.criticalwatch.com