Avahi: denial-of-service vulnerabilities

Users of Avahi please be advised of a denial-of-service vulnerabilities that has been identified.
To view this vulnerability, possible remedies, and others please check out the Security Advisories at Critical Watch (http://criticalwatch.com/support/security-advisories.aspx)

USN-992-1: [USN-992-1] Avahi denial-of-service vulnerabilities
Details follow:

It was discovered that Avahi incorrectly handled certain mDNS query packets

when the reflector feature is enabled, which is not the default

configuration on Ubuntu. A remote attacker could send crafted mDNS queries

and perform a denial of service on the server and on the network. This

issue only affected Ubuntu 8.04 LTS and 9.04. (CVE-2009-0758)

It was discovered that Avahi incorrectly handled mDNS packets with

corrupted checksums. A remote attacker could send crafted mDNS packets and

cause Avahi to crash, resulting in a denial of service. (CVE-2010-2244)
Read more at http://www.criticalwatch.com