pidgin: Denial-of-Service Vulnerability

Users of pidgin please be advised of a Denial-of-Service vulnerability that has been identified.
To view this vulnerability, possible remedies, and others please check out the Security Advisories at Critical Watch (http://criticalwatch.com/support/security-advisories.aspx)

MDVSA-2010:208: [MDVSA-2010:208] pidgin Denial-of-Service
Problem Description:

A security vulnerability has been identified and fixed in pidgin:

It has been discovered that eight denial of service conditions exist

in libpurple all due to insufficient validation of the return value

from purple_base64_decode(). Invalid or malformed data received in

place of a valid base64-encoded value in portions of the Yahoo!, MSN,

MySpaceIM, and XMPP protocol plugins and the NTLM authentication

support trigger a crash. These vulnerabilities can be leveraged by

a remote user for denial of service (CVE-2010-3711).Read more at http://www.criticalwatch.com

 

Advertisements