MySQL: Multiple Vulnerabilities

Users of MySQL please be advised of Multiple Vulnerabilities that has been identified.
To view this vulnerability, possible remedies, and others please check out the Security Advisories at Critical Watch (http://criticalwatch.com/support/security-advisories.aspx)

MDVSA-2010:223: [MDVSA-2010:223] mysql Multiple Vulnerabilities
Problem Description:

Multiple vulnerabilities were discovered and corrected in mysql:

* During evaluation of arguments to extreme-value functions (such

as LEAST() and GREATEST()), type errors did not propagate properly,

causing the server to crash (CVE-2010-3833).

* The server could crash after materializing a derived table that

required a temporary table for grouping (CVE-2010-3834).

* A user-variable assignment expression that is evaluated in a logical

expression context can be precalculated in a temporary table for GROUP

BY. However, when the expression value is used after creation of the

temporary table, it was re-evaluated, not read from the table and a

server crash resulted (CVE-2010-3835).

Read more at http://www.criticalwatch.com

 

Advertisements